Fedora 18 vyjde za několik dní a mnoho uživatelů už to čekání nemohlo vydržet a na novou verzi Fedory již přechází. Někteří však mohou být překvapení, že zavedené postupy pro nainstalování kodeků nefungují. Je to způsobené tím, že většina* multimediálních aplikací přešla na novou verzi GStreameru, konkrétně verzi 1.0. Kvůli tomu se změnily názvy balíčků, které přidávají do GStreameru multimediální podporu. Aby toho nebylo málo, autoři RPM Fusion se rozhodli přejít z multimediální knihovny FFmpeg na její fork libav.

Abyste dosáhli plné multimediální podpory v aplikacích, které používají jako backend GStreamer (Totem, Rhythmbox, Banshee,…), musíte po přidání RPM Fusion doinstalovat balíčky následujícím příkazem:

sudo yum install gstreamer1-plugins-ugly gstreamer1-libav

V souvislosti s RPM Fusion se vyskytuje ještě jeden problém. Pokud si tento repozitář přidáte pomocí nainstalování daného balíčku, jak je doporučováno i v uživatelské příručce, můžete mít problémy s ověřením balíčků. Při instalaci se totiž přidají klíče s jiným názvem, než na jaký je potom odkazováno při ověřování, a yum začne hlásit problémy s ověřením podpisu balíčků. Jedná se s největší pravděpodobností o chybu na straně RPM Fusion. Následující dva příkazy by měly problém vyřešit:

sudo link /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-18-primary /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-18-x86_64
sudo link /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-18-primary /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-nonfree-fedora-18-x86_64

* Očividně ne všechny aplikace už nový GStreamer používají. Třeba ty založené na Phononu (Kaffeine a další aplikace KDE) stále používají starý GStreamer. V případě těchto aplikací se nic nemění a lze postupovat podle návodu v příručce.